Users will no longer be able to log into Suomi.fi via e-identification on old terminals and browser versions after 5 June

Strong identification in Suomi.fi e-Identification will no longer be possible with certain old devices after 5 June. It will no longer be possible to use strong identification with old devices or internet browsers as they pose information security risks.

 Operating systems/browsers the use of which will be blocked in Suomi.fi e-Identification will the transition to TLS 1.2:

  • Android 2.3.7
  • Android 4.0.4
  • Android 4.1.1
  • Android 4.2.2
  • Android 4.3
  • IE 7 / Vista
  • IE 10 / Win Phone 8.0
  • IE 8-10 / Win 7
  • Safari 6.0.4 / OS X 10.8.4
  • Safari 5.1.9 / OS X 10.6.8
  • Java 7u25
  • Baidu Jan 2015
  • OpenSSL 0.9.8y

There are very few devices or operating systems to which this change applies in use in Finland. Those who use the devices or systems in question will be notified of the change in the Suomi.fi user interface.

Read the Finnish Transport and Communications Agency Traficom’s press release for more information: Old terminal equipment will not support strong electronic identification after the new year

Inquiries

tunnistus-kayttoonotot@vrk.fi